Back to overview
Degraded

Increased screenshot rendering error rates

Nov 18 at 01:08pm UTC
Affected services
Stillio Screenshot Engine

Resolved
Nov 18 at 02:56pm UTC

Cloudflare has rolled out a fix to their global outage and we can confirm that screenshot errors have subsided and operations are back to normal.

Created
Nov 18 at 01:08pm UTC

We are currently experiencing a small increased error rate in our screenshot engine, which is causing some screenshots to fail. This is due to a large-scale outage at Cloudflare. We will continue to monitor the situation and provide feedback as we learn more.