Back to overview
Downtime

Incident: Scheduled screenshot delays due to AWS outage

Oct 20 at 09:24am UTC
Affected services
Stillio Screenshot Engine

Resolved
Oct 20 at 12:03pm UTC

Good news: everything’s back! The scheduler’s working normally again, and any screenshots that missed their slot during the AWS hiccup were queued up and captured right after we came back online — just a bit delayed, not lost. New captures will run on their regular schedules. Sorry for the interruption and thanks for bearing with us!

Updated
Oct 20 at 11:05am UTC

During the AWS outage, the scheduler couldn't mark screenshots as successful. Consequently, those captures might be recorded as failed instead of delayed. We need more time to investigate if they can still be processed.

Future scheduling is not affected in principle, but because we have not yet identified the root cause of the failure we have paused new scheduled captures temporarily as a precaution.

The app is still accessible and past screenshots remain available.

We’re investigating the failure root cause and monitoring AWS closely. We’ll resume scheduling and update this status as soon as we can. Sorry for the inconvenience.

Created
Oct 20 at 09:24am UTC

We’re currently experiencing delays in scheduled screenshot captures because of a widespread incident at Amazon Web Services that is impacting our scheduling system.

What’s happening

  • Screenshots scheduled during the outage will be captured once our scheduling system is fully restored, so they will be delayed.
  • Future scheduling is not affected — any captures you schedule now will run normally once the system is back.
  • The app remains accessible and past screenshots are available as usual.

What we’re doing

  • Monitoring AWS and our systems closely and will resume normal capture processing as soon as the scheduling service is restored.

Expected impact

  • Only screenshots that were due during the outage will be delayed.
  • Delayed screenshots will be executed when the system recovers.

We’ll update this status when the scheduling system is back to normal. Thank you for your patience.