Back to overview
Degraded

Images take longer to load than usual

Feb 05 at 08:44am UTC
Affected services
Stillio Screenshot Delivery Network (sdn.stillio.com)

Resolved
Feb 05 at 10:13am UTC

The loading times of images in our app have been restored, everything is working fine again. We will continue monitoring over the next few hours.

Created
Feb 05 at 08:44am UTC

We are currently experiencing longer loading times for both thumbnail and full-size images from our content delivery network (CDN). Our team is actively investigating the issue in order to identify the cause and implement a resolution. Rest assured that this only affects the display of the screenshot images, not the process of capturing the screenshots itself.