Back to overview
Degraded

Limited service delivery

Jun 13 at 08:10pm UTC
Affected services
Stillio Web App (app.stillio.com)
Stillio Screenshot Engine
3rd party integrations

Resolved
Jun 13 at 09:39pm UTC

We are pleased to inform you that all our systems are now functioning normally. The backlog has been successfully processed, and we have captured screenshots as per usual. However, in a few isolated cases, thumbnails were not generated. Rest assured that this does not affect your ability to view the full screenshot by simply clicking on the provided link.

We sincerely apologize for any inconvenience this may have caused you. Our team has worked diligently to resolve these issues promptly. If you continue to experience any difficulties or require further assistance, please do not hesitate to contact our support team. We are here to help you.

Thank you for your understanding and patience during this time.

Updated
Jun 13 at 09:07pm UTC

Here's a quick update on the recent issue we’ve been experiencing. We are happy to report that we have identified the root cause of the problem and our teams are working diligently to get all services back up and running smoothly. At this time, most services are now recovering and we expect everything to be fully operational in no time. Thank you all for your patience and understanding while we worked through this challenge. We will post an update when all things are back to normal.

Created
Jun 13 at 08:10pm UTC

There is currently an issue within our infrastructure that is causing interruption of our services. We are still assessing the full impact of the outage and will post more information as we receive it. The app is currently accessible but you may still experience issues whilst we take action to resolve what we can from our end. For more information see https://health.aws.amazon.com/health/status