Back to overview
Degraded

Elevated errors and high response time for uncached image

Feb 20 at 08:50pm UTC
Affected services
Stillio Screenshot Delivery Network (sdn.stillio.com)

Resolved
Feb 20 at 10:12pm UTC

A fix has been applied, and image loading times will be back to normal soon. Thanks for your patience!

Created
Feb 20 at 08:50pm UTC

Our content delivery network (CDN) experiences degraded performance, causing the images to load very slowly or not at all. This concerns both the display of screenshots and thumbnails. It does not affect the screenshot capture process, which operates as normal and as scheduled.

The problem has been identified, and we're working on a fix. We're sorry for the inconvenience.