Get in touch
Back
Maintenance

Aug 13 (Sat) - Stillio App upgrade

Completed 13 Aug at 08:00am UTC.

Stillio Web App (app.stillio.com)
Updated

The upgrade has been completed successfully! Please note that you will need to log in the first time when accessing the updated app.

Posted 13 Aug at 08:03am UTC.
Completed

Posted 13 Aug at 08:00am UTC.
Started

After months of developing and testing, the new Stillio web app will launch. 🚀 Our beta preview was available for everyone to see and use, and now it replaces the app that has been around since 2016.

⚠️ During the migration, you will not be able to use the web app. The screenshot scheduling and capturing process is not affected during the migration: it will continue to work as usual.

Posted 13 Aug at 06:00am UTC.