Get in touch
Back
Downtime

Database issues.

Started 22 Jul at 02:59pm UTC, resolved 22 Jul at 08:02pm UTC.

Stillio Web App (app.stillio.com) Stillio API (api.stillio.com) Stillio Screenshot Engine
Resolved

All systems are up and running again. We're sincerely sorry for the app being unavailable for so long and for the delay in the screenshot processing.

A bug in our software caused the problem. This bug prevented the app from displaying Webpages and their associated Screenshots. Unfortunately, finding and fixing the bug took us longer than expected. Now that we patched the bug, all data is accessible as before. Again, we're very sorry for the inconvenience caused, and we have made more substantial commitments with the development team to prevent this from happening in the future.

Posted 22 Jul at 08:02pm UTC.
Updated

The screenshot engine is running again and processing all screenshot requests. The backlog of delayed screenshot jobs is getting smaller every minute and will soon be back to normal. Screenshots that were scheduled to be processed during the downtime have been delayed, and are being captured soon now. We're very sorry for this.

The web app is still not accessible as the development team is applying fixes. As soon as we have news, we'll let you know. Thanks again for your patience.

Posted 22 Jul at 06:00pm UTC.
Updated

We have identified the root cause of the issue and are working on a fix. Thanks for your patience and our sincere apologies for the inconvenience.

Posted 22 Jul at 04:26pm UTC.
Created

We cannot load and show screenshot data. We're investigating the issue.

Posted 22 Jul at 02:59pm UTC.